FLXS1 Firmware 19


#21

I thought this at first too, but realized some of them appear to save immediately, and others you have to exit the global screen in order to make them saved. If you always exit the global screen everything appears to save.


#22

Masking a channel during pattern save masks the channel but also selects the channel options, exiting the pattern save mode.

Steps to reproduce:

  • Make a sequence
  • shift + pattern
  • press channel button
    You’re now looking at the channel options screen.
  • shift + pattern
    The channel now shows as masked but I don’t think you’re supposed to have left the pattern save screen.

This same behavior occurs when picking a pattern, and masking/unmasking channels on pattern load.


#23

When changing patterns with the trigger set to ch1 release, most of the steps on the first play through of the new sequence will not change pitch or trigger their gates.

Steps to reproduce:

  • Create two 5 step sequences and save both
  • Load the first sequence
  • Press “play”
  • Press “pattern”
  • Change trigger to “ch1 rese”
  • Select the second pattern

The 4x4 grid shows the highlighted step moving as expected, but cv1a is not following the step and gt1 is closed until the sequence has gone through completely once.

By the way, I’ve had the FLXS1 lock up on me twice while saving and loading sequences, and I’m not entirely sure what combination of things I’m doing to make it do that. If I figure it out I’ll report back.

EDIT – I think I figured out steps to reproduce the crash I was seeing:

  • Create two 5 step sequences and save both
  • Load the first sequence
  • Press “play”
  • Press “pattern”
  • Chain the first sequence to the second sequence
  • Press “pattern” again to exit sequence mode
  • Press “play” to stop

At this point pressing “play” again to start the chained sequence causes FLXS1 to lock up.

My two patterns both had a channel direction of pendulum on ch1. Not sure if that matters or not.


#24

Thanks to everyone for testing and suggestions with Firmware 19. This week I have been working on new hardware (have some serious deadlines for superbooth), and next week I will be in NYC to help set up my dad’s art show. I should be able to get some of these problems fixed after that.

Not hard to do, I’ll look into it for the next update

Global settings are indeed saved after you exit the global menu. The other option is to save them over and over and over again, and that stresses the flash memory IC, which is limited to 100,000 writes over its lifetime, which should last you pretty much a lifetime, but saving after exiting increases that by an order of magnitude.


#25

Great this module is finally getting its own forum, some positive feedback and constructive ideas keeps everything moving along.

Can’t wait for per step probability :wink:


#26

Found a slight bug with save pattern menu. When you press to select/deselect tracks it kicks you back to the channel edit screen.


#27

Bug report if set to “ext clock” and external clock being “clock port” when restarting module ext clock is not detected. Scrolling through options and cycling back to “clock port” and clock input is detected again.


#28

Both noted, and should be fixed in the next update


#29

Small addition related to this bug:

When you go in pattern save mode and choose a slot with the matrix keys, the step on the selected key gets activated in the sequence.


#30

When synced to midi via USB, FLXS-1 does not seem to recognize clock reset.


#31

I experience crashes when synced to Midi clock via the 3.5mm plug.

After a short while from receiving the clock info, encoder click select stops functioning and any interaction hereafter is impossible with the unit. I can scroll through the menus, but can not select anything with the click.


#32

When you fix the bugs, I hope it’s possible to add a division of 16
to the clock division
I do a lot of sequences that are very slow


#33

What firmware are you on? FLXS1 should receive clock reset from USB Midi (as a USB Device, not a USB Host)

What are you syncing to that is crashing FLXS1 from the 3.5mm plug?

T


#34

Found a Bug, track 3 - start on First step 1 - step count 64 - clock div 4
If I change clock division to 4 it freezes the flxs1
a division of 3 or less and 5 or more is fine. just when it’s set to 4


#35

I don’t know if anyone else saw this but the FLXS1 has some competition now.

Tenkai, hope all is well. Are we gonna get more songs?


#36

Hey, sorry for the very late reply.

I am on version 19a. I will do some more tests with USB Midi, maybe my DAW is not set up properly, even though it works with other gear. I’ll get back to you.

And, I am syncing to an Analog Rytm MK1 through the 3.5 plug.

Edit: I just tested the 3.5mm plug with various gear. I get the same result. The FLXS-1 sort of freezes. I can not select with encoder click, and I can not load any sequences. I can scroll through all the menus and all the other buttons seems to work as they should.


#37

finally signed up for the forum after how long?. glad to find this update! prob per step is awesome!


#38

heyyyyyyyy. so, just (finally) updated to v19a, and it wipes my saves when i power cycle. when i hit Shift Save, choose a spot, then Shift Save it saves it. i can save to Patter 01, go to Pattern 02, come back to Pattern 01 and all the data is there. but if i turn my rack off then on there are zero saves available.

tried reloading the update 5 times, loads fine each, the boot up does take about 5 times as long as before, but every time i’ve updated it has the same zero saves on reboot problem.

help?


#39

annnnnnnnnnnnnnnd never mind. missed the hold PLAY STOP RECORD wiping step.

DURP.

WORKS FINE NOW.

IGNORE ME.


#40

What’s the step? I had this, but just changed back without questioning?

Chris.