I've been trying to update the firmware but the teensy app just won't work, could someone please try to help me out?


#1

Hi! I’ve been trying to update the firmware for several months now and I keep getting stuck at the same problem. Whenever I drag the firmware .hex file onto the teensy app, the app says “file too large” and nothing else happens. I’ve tried it on 3 different computers now, 2 running MacOs and 1 Windows and I keep running into this problem, which leads me to suspect that I’m doing something wrong.
I’ve talked to Tenkay about this several times and he’s been absolutely great and really tried a lot but still no success. I’ve re-downloaded the Teensy app and the firmware files several times, ran the app from the desktop instead of from the dmg and used several different computers.
Any other ideas?
Getting a bit desperate over here b/c I’d love to try the new firmwares.

best
Julian

Edit: I just tried to open one of those “LED Blink” files on the teensy website with the teensy app, and those worked just fine…


#2

OMG IT WORKED. I read in another forum that people have been successful by connecting the device via usb and then adding the hex file, which worked!
@tenkay: maybe you want to edit that in your update instructions, since you told me you’ve had several people with this problem!


#3

Glad that it worked out for you :smiley:

Can you paste a link to the forum you are talking about? I am not entirely sure about what you did differently.


#4

here’s the forum: https://flybrix.zendesk.com/hc/en-us/community/posts/115000802348-Teensy-Loader-File-Too-Large
literally all I had to do was connect the flxs1 to my computer. I was hesitant to do that before b/c I didn’t want it to boot the firmware before it’s loaded onto the teensy app, but connecting the flxs1 is exactly what was necessary to get the teensy app to open the firmware file. I’d just update your instructions to something like this:

  1. download the teensy loader and the firmware
  2. unzip both, open the teensy loader
  3. drag the firmware onto the teensy loader, the loader will display “file too large”
  4. connect the flxs1 to your computer via usb
  5. hit program using a paperclip, the teensy app will now show the correct file size and commence updating
  6. done

#5

wow! maybe you found the reason people get this error!
I never understood why it always worked for me, and some people would consistently get this “file too large” error. It makes sense since the Teensy Loader app recognizes the Teensy 3.2 inside FLXS1 (as opposed to previous teensies that have smaller flash memory storage).

I guess I just assumed people had it plugged in already…

Glad its working for you now!


#6

if i remember correctly you can also load any really small hex file, then load the bigger hex file you want to use, it won’t complain. i had this problem some years ago. i vaguely remember doing that.